hy3/flake.nix
2024-07-21 11:22:09 -07:00

39 lines
1.2 KiB
Nix

{
inputs = {
hyprland.url = "git+https://github.com/hyprwm/Hyprland?submodules=1&rev=928d1dd38a6e4a791d4a4374a4a3bf02311adbb2";
};
outputs = { self, hyprland, ... }: let
inherit (hyprland.inputs) nixpkgs;
hyprlandSystems = fn: nixpkgs.lib.genAttrs
(builtins.attrNames hyprland.packages)
(system: fn system nixpkgs.legacyPackages.${system});
hyprlandVersion = nixpkgs.lib.removeSuffix "\n" (builtins.readFile "${hyprland}/VERSION");
in {
packages = hyprlandSystems (system: pkgs: rec {
hy3 = pkgs.callPackage ./default.nix {
hyprland = hyprland.packages.${system}.hyprland;
hlversion = hyprlandVersion;
};
default = hy3;
});
devShells = hyprlandSystems (system: pkgs: {
default = import ./shell.nix {
inherit pkgs;
hlversion = hyprlandVersion;
hyprland = hyprland.packages.${system}.hyprland-debug;
};
impure = import ./shell.nix {
pkgs = import <nixpkgs> {};
hlversion = hyprlandVersion;
hyprland = (pkgs.appendOverlays [ hyprland.overlays.hyprland-packages ]).hyprland-debug.overrideAttrs {
dontStrip = true;
};
};
});
};
}